Как отобразить «0» вместо #N/A при использовании функции ВПР в Excel 2013

Формула ВПР в Microsoft Excel — один из самых эффективных способов поиска данных в электронных таблицах. Наряду с формулой конкатенации я обнаружил, что это один из наиболее полезных инструментов в Excel. Это может сэкономить невероятное количество времени по сравнению с ручным поиском данных ячеек, а также имеет дополнительное преимущество повторяемости и точности.

Но если формула ВПР не может найти искомую информацию, она отобразит ошибку в виде #Н/Д. Это может быть проблематично, особенно если важен внешний вид ваших данных. К счастью, вы можете внести небольшое изменение в формулу ВПР, чтобы отображать «)» вместо сообщения об ошибке #Н/Д.

Как изменить формулу ВПР в Excel 2013 для отображения нуля вместо #N/A

В приведенных ниже шагах предполагается, что у вас уже есть существующая формула ВПР в электронной таблице, но вы хотите, чтобы она отображала «0» вместо #Н/Д. Формула будет отображать #NA, если она не найдет нужную информацию. Следуя приведенным ниже шагам, он будет заменен на «0».

Шаг 1: Откройте электронную таблицу, содержащую значение #Н/Д, которое вы хотите заменить.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

открыть электронную таблицу с ошибкой vlookup

Шаг 2: Выберите ячейку, содержащую формулу, которую вы хотите изменить.

выберите ячейку, содержащую формулу для изменения

Шаг 3: Измените существующую формулу ВПР, включив в нее информацию ЕСЛИОШИБКА. Это включает в себя добавление фразы «ЕСЛИОШИБКА(» в начало формулы и строки «, 0)» в конец формулы. Например, если ваша формула раньше была:

=ВПР(A2, ‘Источник данных’!A$:N$6, 14, ЛОЖЬ)

Затем вы изменили бы его так:

=ЕСЛИОШИБКА(ВПР(A2, ‘Источник данных’!A$:N$6, 14, ЛОЖЬ), 0)

как отобразить ноль вместо #n/a в формуле vlookup excel 2013

Шаг 4: Скопируйте и вставьте новую формулу в ячейки, где вы хотите отображать «0» вместо #N/A.

скопируйте и вставьте измененную формулу

Обратите внимание, что вы можете отображать строку символов, которую хотите. Это не обязательно должен быть 0. Например, если вы использовали формулу ВПР для вставки адреса, вы можете сделать формулу =ЕСЛИОШИБКА(XX, YY:ZZ, AA, ЛОЖЬ), «БЕЗ АДРЕСА») . Это будет отображать фразу «НЕТ АДРЕСА» вместо 0, когда Excel не может найти нужные данные.

использование пользовательской текстовой строки в качестве сообщения об ошибке в Excel 2013

Другая полезная формула, которую вы можете использовать, называется СЦЕПИТЬ. В этой статье мы покажем вам, как это можно использовать для объединения данных из нескольких ячеек.

Вы также можете узнать, как вычитать в Excel, с помощью другой формулы, которая может пригодиться.

информационный бюллетень Solveyourtech.com

Отказ от ответственности: Большинство страниц в Интернете содержат партнерские ссылки, в том числе некоторые на этом сайте.

Программы для Windows, мобильные приложения, игры - ВСЁ БЕСПЛАТНО, в нашем закрытом телеграмм канале - Подписывайтесь:)

Похожие записи

Добавить комментарий

Ваш адрес email не будет опубликован.